0

I ran vagrant provision and I get this error:

at: apt-get install -y -qq software-properties-common python-software-properties

error message:
WARNING: The following packages cannot be authenticated!
python-software-properties

When I try run sudo apt-get update on the VM I get these errors.

W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/trusty/InRelease
W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/trusty-updates/InRelease
W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/trusty-backports/InRelease
W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/trusty/Release.gpg  Could not resolve 'us.archive.ubuntu.com'
W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/trusty-updates/Release.gpg  Could not resolve 'us.archive.ubuntu.com'
W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/trusty-backports/Release.gpg  Could not resolve 'us.archive.ubuntu.com'
W: Some index files failed to download. They have been ignored, or old ones used instead.

Note that there is no InRelease file in these directories:

http://us.archive.ubuntu.com/ubuntu/dists/trusty/

http://old-releases.archive.ubuntu.com/ubuntu/dists/trusty/InRelease

I am using:

Host machine: OS: Ubuntu 16.04 x86_64 vagrant: Vagrant 1.8.5

VM: box 'geerlingguy/ubuntu1404' (v1.1.3) for provider: virtualbox

config.yml:

vagrant_hostname: iemp.local
vagrant_machine_name: iemp

vagrant_box: geerlingguy/ubuntu1404
php_version: "5.6"
drupal_major_version: 7
drush_version: "7.x"

php_packages:
  - php5
  - php5-apcu
  - php5-mcrypt
  - php5-cli
  - php5-common
  - php5-curl
  - php5-dev
  - php5-fpm
  - php5-gd
  - php5-sqlite
  - php-pear
  - libpcre3-dev
php_conf_paths:
  - /etc/php5/fpm
  - /etc/php5/apache2
  - /etc/php5/cli
php_extension_conf_paths:
  - /etc/php5/fpm/conf.d
  - /etc/php5/apache2/conf.d
  - /etc/php5/cli/conf.d
php_fpm_daemon: php5-fpm
php_fpm_conf_path: "/etc/php5/fpm"
php_fpm_pool_conf_path: "/etc/php5/fpm/pool.d/www.conf"
php_mysql_package: php5-mysql

build_makefile: false
build_composer: false
build_composer_project: false
install_site: false

vagrant_synced_folders:
  - local_path: ./
    destination: /var/www/drupalvm
    type: nfs
    create: true

1 Answer 1

0

I ended up reinstalling the host machine, Virtual Box and Vagrant. It seems like I broke something by manually deleting the Virtual Machine via the Virtual Box Admin Interface.

With the new installation and the same configuration it worked perfectly.

I suggest using vagrant destroy to delete your virtual machine files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.