0

http://www.ascoworld.com/services

On the above page, there is a block with three icons that links to the wrong pages. I want to change where they link to but can't seem to find out how. Apologies, but I am as new as can be at this. I didn't create the website and have never used Drupal before, I just got passed it and told to fix these issues.

Thanks!

enter image description here

1
  • It's look like its created using views. try to check it here /admin/structure/views and look for views services
    – iamroald
    Aug 24, 2016 at 10:10

3 Answers 3

0

The page layout is broken but I assume that you are talking about Services menu block. Based on the HTML source it is a menu block and a main menu to be specific. So to the change the link go to Structure > Menus > Main Menu and change the link path there.

UPDATE:

Since the page is broken in my end my above answer is wrong. As @iamroald comment it is created via Views. Go to Structure > Views > Services. It seems like there is a Token substitution in there.

0

The Link is coming from the content path field that means node link. If you need to add custom link. you need to create a field in service group content type. Then edit all the contents of type "service group" and add your link there. After that add that field in your view and delete content path field from view.

0

Updated Answer:

The views block content is created in node, node type service group. so if you wanted to change the link you can update the alias pattern here /admin/config/search/path/patterns.

enter image description here

or manually update it here admin/config/search/path

enter image description here

11
  • Thanks! You seem to be right. However, when I go to edit, I can see the three links but no option to change them (screenshot added to question). Aug 24, 2016 at 10:28
  • Click the content path and you can override its link
    – iamroald
    Aug 24, 2016 at 10:29
  • Updated image. I can't edit it by clicking the path. And when I go to configure > Edit Content: Path – there is no option to change it. Aug 24, 2016 at 10:38
  • Sorry just ignore the last comment, it is made in content type and it shows the result base on the existing content
    – iamroald
    Aug 24, 2016 at 10:41
  • I mean the content
    – iamroald
    Aug 24, 2016 at 10:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.