0

I am using Drupal 7 on Ubuntu 16, Apache 2.4.20, and PHP 7.0.9.

When attempting to use a Feed importer on PHP 7.0, I receive a 500 AJAX Error that gives no Response Text.

enter image description here

Additionally, nothing is shown in the error logs.

However, when switching my Apache PHP version back to 5.6, it works just fine.

Is there any support for Feeds on PHP 7.0 this yet? Or should I stay away from PHP 7 for a while?

  • looks to me that you should be reporting this into the module's issue reports – No Sssweat Aug 25 '16 at 23:36
  • I am using feeds with PHP 7 with no issues. Maybe your problem is elsewhere. – pierostz Aug 26 '16 at 6:08
  • Did you had a look at your PHP error log, to see if there is a more detail message ? – TytooF Aug 27 '16 at 8:53
0

As suggested in the comments, I reported this issue and found the solution.

The issue was the feeds tamper module. Updating from Feeds Tamper version 7.x-1.1 to 7.x-1.x-dev solved the issue.

So if you are using PHP 7.0, I recommend using Feeds version 7.x-2.0-beta2 and Feeds Tamper 7.x-1.x-dev.

Here is a link to the issue I opened: https://www.drupal.org/node/2790355#comment-11571211

I hope this helps others with this situation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.