0

I have nearly 150 Panel pages and different template files. I generated lot of blocks using Node Block module to be used in the Panel pages.

I guess this is causing memory issues in both MySQL and Apache configuration. Any solution for this memory issues?

My global memory_limit is 128M. Only after setting 512M in settings.php, my custom Drupal View is generating the output (otherwise, it generated a 502 error).

Is there a way so that I can set memory_limit only for my custom View?

  • As I already mentioned your Hosting server does not allow you to change memory limit, you have to contact them for that – NTT Aug 26 '16 at 11:47
  • Is this about Drupal 5, or any release above that? – Pierre.Vriens Aug 26 '16 at 11:48
  • It is Drupal 7. – Kiran Aug 26 '16 at 11:50
  • @Nagarjuna: Its not about memory limit. I can see the reflection clearly. I increased the memory limit to 512M , only then the View started rendering the output. I updated in the description as well. Please see it. – Kiran Aug 26 '16 at 11:51
1

Refer to the Changing PHP memory limits document, you can use

ini_set('memory_limit', '64M');

which should be in your settings.php file.

| improve this answer | |
  • No, I have memory_limit set to 128M. But, this is not working for the View. I need atleast 512M for that view to generate all the records. – Kiran Aug 26 '16 at 9:23
  • Is this in production? because some hosting servers will not allow you to change memory limit, even you set manually – NTT Aug 26 '16 at 9:24
  • Yes, its in Production environment. – Kiran Aug 26 '16 at 9:37
  • Make sure that your memory limit works, as i already told you that some hosting servers will not allow you to change memory limit – NTT Aug 26 '16 at 9:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.