I can't get past this error while installing drupal on my localhost.

config error -_-

I've chmod'ed permissions on my core /default directory. I've:

/default on 755
/default/files including all subfolders and files on 744 (or 755)
/default/themes including all subfolders and files on 755
/default/modules including all subfolders and files on 755
/default/settings.php and /default/default.settings.php on 444

I've even double checked my apache configs to prepare for drupal8 install.

I'm stumped. I'm out of room to config everything. What's the proper course of action to fix this problem?

  • Check $config_directories['sync'] variable in your site's settings.php file located at "sites/default" directory. There should be a directory inside "sites/default/files" directory named with $config_directories['sync'] variable.
    – Yogesh
    Aug 28, 2016 at 10:57
  • did your problem resolve?
    – Yuseferi
    Mar 17, 2017 at 10:28

7 Answers 7


Create the directory specified in the error. This is fixed in an upcoming release.


Just put this

$config_directories['sync'] = "sites/default/files/config_acqTmp-2017-02-10T00.20.27-8325/sync";  

on settings.php then Create that path with

   mkdir sites/default/files/config_acqTmp-2017-02-10T00.20.27-8325/sync

then rebuild the cache ( if you have drush, drush cr )

  • What are the right permissions of /sync folder? Feb 28, 2017 at 8:18
  • @avalanchaa 755
    – Yuseferi
    Mar 1, 2017 at 11:04
  • Only using this line with my correct file path works fine for my acquai devdesktop drupal project: $config_directories['sync'] = "sites/default/files/config_acqTmp-2017-02-10T00.20.27-8325/sync"; Nov 8, 2018 at 12:47

For beyond Drupal 8.8 versions you need to do the following

$settings['config_sync_directory'] = 'sites/default/files/[your hash name]';


I removed the settings.php file, copy the default.settings.php file (from the drupal 8 older version) to the /sites/default directory and changed it to settings.php On new setup I filled the details with the existing database name, username & password and it's gone. (It's not re-install your database, it uses the existing one)


Same error as others here. I don't use drush. So, I've been mucking around in the setttings.php file. I tried several fixes listed here, but none worked.

Aditya vardhan's trick worked for me :-)

A couple of tips: Your hash name should be the name of the folder in sites/default/files/ that contains the sync folder. If you have any other references in your settings.php to your sites/default/files/ config folder, that should be the same file name, too. (I had one upgrade attempt that had the wrong file name for the config folder)

You can copy that folder path from $config_directories if you have that bit of code, or you can copy the config folder name from the sites/default/files path.

THIS worked for me: $settings['config_sync_directory'] = 'sites/default/files/config_blah_blah';

(Replace config_blah_blah with whatever your folder name is, of course!)

This was an issue for me in upgrading from 8.9.13 to 9.1.4, but the above worked. For you non drush users or non-command line folks, you should be able to fix this with any editor + FTP/SFTP/SSH or CPanel File Editor. Good luck!


I had this issue when using Drupal 8.3.x, and found the procedure is a bit different. After installing Drupal and running the setup, I had this error. I went into sites/default/files, and found that the config folder already existed, so I copied that folder name, and added it to this string in settings.php:

$config_directories['sync'] = "sites/default/files/[your hash name]/sync";

This failed, so following the site instructions, did this:

$config_directories = array(
CONFIG_SYNC_DIRECTORY => 'sites/default/files/[your hash name]',

After this, running update.php and drush cr worked fine.


If you are interested, the config dir can be moved out of the web root. While I haven't had luck with providing a relative path, an absolute path works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.