2

I can't get past this error while installing drupal on my localhost.

config error -_-

I've chmod'ed permissions on my core /default directory. I've:

/default on 755
/default/files including all subfolders and files on 744 (or 755)
/default/themes including all subfolders and files on 755
/default/modules including all subfolders and files on 755
/default/settings.php and /default/default.settings.php on 444

I've even double checked my apache configs to prepare for drupal8 install.

I'm stumped. I'm out of room to config everything. What's the proper course of action to fix this problem?

  • Check $config_directories['sync'] variable in your site's settings.php file located at "sites/default" directory. There should be a directory inside "sites/default/files" directory named with $config_directories['sync'] variable. – Yogesh Aug 28 '16 at 10:57
  • did your problem resolve? – Yusef Mohamadi Mar 17 '17 at 10:28
3

Create the directory specified in the error. This is fixed in an upcoming release.

2

Just put this

$config_directories['sync'] = "sites/default/files/config_acqTmp-2017-02-10T00.20.27-8325/sync";  

on settings.php then Create that path with

   mkdir sites/default/files/config_acqTmp-2017-02-10T00.20.27-8325/sync

then rebuild the cache ( if you have drush, drush cr )

  • What are the right permissions of /sync folder? – johnatasjmo Feb 28 '17 at 8:18
  • @avalanchaa 755 – Yusef Mohamadi Mar 1 '17 at 11:04
  • Only using this line with my correct file path works fine for my acquai devdesktop drupal project: $config_directories['sync'] = "sites/default/files/config_acqTmp-2017-02-10T00.20.27-8325/sync"; – webdevfreak Nov 8 '18 at 12:47
1

I removed the settings.php file, copy the default.settings.php file (from the drupal 8 older version) to the /sites/default directory and changed it to settings.php On new setup I filled the details with the existing database name, username & password and it's gone. (It's not re-install your database, it uses the existing one)

0

I had this issue when using Drupal 8.3.x, and found the procedure is a bit different. After installing Drupal and running the setup, I had this error. I went into sites/default/files, and found that the config folder already existed, so I copied that folder name, and added it to this string in settings.php:

$config_directories['sync'] = "sites/default/files/[your hash name]/sync";

This failed, so following the site instructions, did this:

$config_directories = array(
CONFIG_SYNC_DIRECTORY => 'sites/default/files/[your hash name]',
);

After this, running update.php and drush cr worked fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.