0

I manage a Drupal 7 site with custom theme and I have no FTP access and was not involved in development but I have to manage the content and have every right on the web surface.

The situation

I created some content based on the type article (which has a Body of "Long text and summary" field type and of "Text area with a summary" widget), and a view to show this content.

In the view display (created both Block and Page), Format is set to "Unformatted list" (Force using fields is disabled at the settings), and Show is set to "Content | Teaser". Check the image for the settings.Settings in the first case

With these settings, the content on the editorial view is fine for me: title, a picture, a text and a read more link. Check the image for the result.

enter image description here

Unfortunately, "Read more" does not appear on the page shown for the visitors. Not even not shown, it cannot be found in the html source code.

Note: Read More Control and Read More Link modules are not installed.

Question

Is this behavior intended? Is there a bug in a module? Did I miss something, and there's a way to show "Read more" on the page for the visitors too? Can you please tell me how can I manage to show a "Read more" link to the visitors with the same view settings? I neither understand why modifying the Block style implies the modification of the Page Display, i.e. I modify one of them (like the displayed fields), the other display is modified too automatically.

I already have a workaround, but it is not a solution. What I've done is that I changed the setting and checked the box "Force using fields" at Format: unformatted list and manually added the title, image, text, a manual texted link to read more and a horizontal rule.

  • Thanks you for your advice, but first a Page display was created (I didn't mention previously), and then a Block, so I already have them, still with no result. Description extended, thanks! – DanielTuzes Sep 2 '16 at 17:01
  • Are you using any module related to field permissions? Like this one - drupal.org/project/field_permissions – Vivek Srivastava Sep 2 '16 at 17:16
  • No, I don't have that specific module. I have the following optional modules enabled, which may be related to this question: Core: Contextual links, Field UI, RDF. Display Suite: Display Suite Extras, Display Suite Format, Display Suite UI. Fields: Field Group, User Reference. Other: Pathauto. Views: Embed Views Display, Views Bulk Operations, Views Tree, Views UI. – DanielTuzes Sep 5 '16 at 15:39
0

The "Read More" link is part of the contextual links for each post. So, you need to simply tell Views that you do not want the links shown.

  • Go to: Format, Show, Teaser (the first image you showed in your question).
  • Under the dropdown for "view mode", you will see a checkmark for Display links. Uncheck that and they should disappear.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.