1

themes/custom/teleci/teleci.info.yml:

base theme: bartik
core: 8.x
name: Teleci
package: Custom
type: theme
version: "1.1"
libraries:
  - teleci/global-styling

themes/custom/teleci/teleci.libraries.yml:

global-styling:
  version: "1.1"
  css:
    theme:
      css/override.css: {}
      css/style.css: {}

I also have custom template in themes\custom\teleci\templates\block--teleci-branding.html.twig that is loading correctly - that means the theme works. But the CSS files are not included (they are not in the generated HTML).

I tried

  • php drupal.phar cr all
  • setting bartik as default and then set my theme back
  • clear browser cache
  • open in private window
  • disable JS/CSS minification in settings
  • check both yml files in yamllint.com
  • disable base theme (bartik)

I'm out of ideas and would appreciate any help :(

Update: I created minimal theme (that does not work as well) for you to test. Could you please test it and let me know if it works for you? https://github.com/tomasfejfar/drupal-simple-theme/ (i have it in /themes/custom)

Update 2: the mini-theme works when I fixed a small bug that is not present in my theme. So there is something about my theme that makes it break.

  • Did you clear/flush the Drupal cache? If you are using drupal console, its suppose to be drupal cr all – No Sssweat Sep 2 '16 at 20:59
  • yes, as noted in list of things I tried: ˙λ php drupal.phar cr all Rebuilding cache(s), wait a moment please. [OK] Done clearing cache(s).˙ – Tomáš Fejfar Sep 2 '16 at 21:25
  • I've never seen it used with php but ok. – No Sssweat Sep 2 '16 at 21:38
  • any errors in the log or in the browser console? – No Sssweat Sep 3 '16 at 4:29
  • Nothing in console, nor error log – Tomáš Fejfar Sep 3 '16 at 7:05
0

Finally it seems to have been fixed. I re-created the same template again under a new name. Checked the diff of theme.info.yml and theme.libraries.yml files - only difference is the name. The new template has all the same functionality the previous had and is 1-to-1 copy except for the name. So only thing I can think of is that while playing with the template something has broken and left some residue in the database that prevented the theme from functioning properly ever again.

Thanks everyone who tried to help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.