I've enabled 'Display Query Log' in the Devel Settings but I don't see any logged at the bottom of my page when I load a page. I just get 'Queries exceeding 5 ms are highlighted.'.

I'm running Drupal on PHP 5.3.2 with a mySQL database.

The issue is present in both the Admin theme and my custom theme.

Other Devel outputs seem to display fine.

Any ideas why the queries aren't showing?

  • May be your queries are getting executed before 5 ms. :) try with 1ms. and ' Collect query info' is also checked ?
    – j2r
    Commented Feb 3, 2012 at 4:28
  • I've tried this. Doesn't seem to be working. Commented Feb 13, 2012 at 14:14
  • worst case scenario uninstall the devel module and install it again.
    – j2r
    Commented Feb 14, 2012 at 7:33

3 Answers 3


You need to check 'Collect query info' in the devel settings: /admin/settings/devel

Otherwise no logs can be shown.


The admin module routinely breaks this. Try disabling it.


I often forget to set appropriate user permissions on the devel module when I re-enable it.

  • Probably not in OP's case, where he can see the 'Queries exceeding 5 ms are highlighted.' line. But others might not see any output at all, because of the permissions you mention.
    – user18099
    Commented Apr 27, 2017 at 14:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.