2

So, I just updated my site to Drupal 7.50, and in addition to being informed of a host of modules that weren't properly uninstalled, it seems that I can no longer update modules through the administrative interface. I have a long list of module updates and it will be annoying to do all of them manually.

So is there some setting that changed? Or how can I get back to being able to update modules through the admin UI. I've tried a few at a time, as well as one at a time. I get the following warning after trying to update

The file could not be created.
https://ftp.drupal.org/files/projects/google_analytics-7.x-2.3.tar.gz could not be saved to temporary://update-cache-d103ec38/google_analytics-7.x-2.3.tar.gz.
The file could not be created.
https://ftp.drupal.org/files/projects/webform-7.x-4.14.tar.gz could not be saved to temporary://update-cache-d103ec38/webform-7.x-4.14.tar.gz.
Downloading updates failed:

Failed to download google_analytics from https://ftp.drupal.org/files/projects/google_analytics-7.x-2.3.tar.gz
Failed to download webform from https://ftp.drupal.org/files/projects/webform-7.x-4.14.tar.gz
  • in addition to being informed of a host of modules that weren't properly uninstalled Did you place all those modules back into the modules folder (via FTP or Drush) and then uninstall them? – No Sssweat Sep 9 '16 at 8:48
  • No, not yet because some of those modules were custom from a previous site maintainer that I don't have access to. I will have to manually remove them from the db. Are you saying that the update mechanism is failing because of the improperly removed modules? this wasn't an issue previously – nizz0k Sep 9 '16 at 8:51
  • perhaps, I had client that had 104 modules but I never tried installing anything when I was getting the warnings, so I can't tell you for sure. – No Sssweat Sep 9 '16 at 8:55
  • We have 90 something modules, I can track down all but some of the custom modules. I have to go back through old site backups to see if I can track down some of the missing modules...what a pain. – nizz0k Sep 9 '16 at 8:57
  • what a pain I feel ya. Hhhhmmm The file could not be created. this makes me believe that it could be a folder permission issue. Is your server runing on Ubuntu? If yes, make sure the folder owner is www-data – No Sssweat Sep 9 '16 at 8:58
3

This is most likely a problem with your file permissions. A quick test on simplytest.me showed that module installation is not broken in 7.50.

I would try to check the file_temporary_path variable under:

"Administrator -> Configuration -> Media -> File System"

And see that the web server can write to the configured directory.

If my assumption is correct, then also all other file uploads will fail, so it might be a good idea to test uploading an image to an article, too.

  • this was it. thnx. – nizz0k Sep 11 '16 at 12:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.