1

Just before the title field I have added a "Content: Edit link" in several of my views to make it easy to edit nodes. In the Rewrite section for this item I have added this to change the edit symbol:

<img src="/sites/all/themes/mysite/images/application_edit.png" alt="Edit symbol" height="16" width="16">

Now I have discovered that the Edit link redirects to the wrong node. The link looks like this:

www.mysite.com/node/25305/edit?destination=node/24207

How can I make it direct the user to the right node? Should I enable Output this field as a link and add the node ID manually? I am not quite sure how to do that using the replacement patterns.

0

OK, I solved it the easy way. I enabled "Output this field as a link", added the field "Content: nid" as the first field and then changed my rewritten field to this:

<a href="http://www.mysite.se/node/[nid]/edit?destination=node/[nid]"><img src="/sites/all/themes/mysite/images/application_edit.png" alt="Edit symbol" height="16" width="16"></a>

And now it works. Hope this helps somebody.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.