0

When a node is edited and saved the Cache expiration module should clear the cache on that node, which it does. However if that same node is used in a View, I have discovered that the old content still shows. Unfortunately 90% of the main content is shown using Views.

So in the cache expiration configuration page I have ticked the "Custom pages" option and entered products|wildcard, because all sub pages after products/ contains views that need to be cleared. But this does not work.

I have tried to use drush cc views (success message), which does not work, drush cc all does not show the new content either. The only thing that actually works is to go to admin/config/performance and click the Clear all caches button.

What is the best way to sort this problem, so that the Cache expiration module also works on Views?

EDITED:

I haven't found the solution for this problem yet. Any ideas would be really helpful. Anyone? I should probably also mention that I use the Boost module to chache my pages, along with the Cache Expiration module.

0

Finally the solution was simple. Apparently you cannot use aliases in the Custom pages settings in the Cache expiration module. By adding taxonomy/terms|wildcard in the custom pages box, and also setting the cache to None in each concerned View (in the Advanced section), the cache expiration worked as wanted.

Hope this helps, if anyone else has this problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.