1

Started getting the following error on my views admin page after updating to 8.2.0-rc1, have tried searching for related issues with no success as yet. Seeking help from someone better versed in backend drupal than I currently am.


The website encountered an unexpected error. Please try again later.

Drupal\Core\Entity\EntityMalformedException: The "view" entity cannot have a URI as it does not have an ID in Drupal\Core\Entity\Entity->toUrl() (line 179 of core/lib/Drupal/Core/Entity/Entity.php). Drupal\Core\Config\Entity\ConfigEntityBase->toUrl('edit-form', Array) (Line: 171) Drupal\Core\Entity\Entity->urlInfo('edit-form', Array) (Line: 408) Drupal\Core\Config\Entity\ConfigEntityBase->urlInfo('edit-form') (Line: 146) Drupal\Core\Entity\EntityListBuilder->getDefaultOperations(Object) (Line: 33) Drupal\Core\Config\Entity\ConfigEntityListBuilder->getDefaultOperations(Object) (Line: 155) Drupal\views_ui\ViewListBuilder->getDefaultOperations(Object) (Line: 122) Drupal\Core\Entity\EntityListBuilder->getOperations(Object) (Line: 203) Drupal\Core\Entity\EntityListBuilder->buildOperations(Object) (Line: 185) Drupal\Core\Entity\EntityListBuilder->buildRow(Object) (Line: 87) Drupal\views_ui\ViewListBuilder->buildRow(Object) (Line: 223) Drupal\views_ui\ViewListBuilder->render() (Line: 22) Drupal\Core\Entity\Controller\EntityListController->listing('view') call_user_func_array(Array, Array) (Line: 123) Drupal\Core\EventSubscriber\EarlyRenderingControllerWrapperSubscriber->Drupal\Core\EventSubscriber{closure}() (Line: 574) Drupal\Core\Render\Renderer->executeInRenderContext(Object, Object) (Line: 124) Drupal\Core\EventSubscriber\EarlyRenderingControllerWrapperSubscriber->wrapControllerExecutionInRenderContext(Array, Array) (Line: 97) Drupal\Core\EventSubscriber\EarlyRenderingControllerWrapperSubscriber->Drupal\Core\EventSubscriber{closure}() call_user_func_array(Object, Array) (Line: 139) Symfony\Component\HttpKernel\HttpKernel->handleRaw(Object, 1) (Line: 62) Symfony\Component\HttpKernel\HttpKernel->handle(Object, 1, 1) (Line: 57) Drupal\Core\StackMiddleware\Session->handle(Object, 1, 1) (Line: 47) Drupal\Core\StackMiddleware\KernelPreHandle->handle(Object, 1, 1) (Line: 99) Drupal\page_cache\StackMiddleware\PageCache->pass(Object, 1, 1) (Line: 78) Drupal\page_cache\StackMiddleware\PageCache->handle(Object, 1, 1) (Line: 47) Drupal\Core\StackMiddleware\ReverseProxyMiddleware->handle(Object, 1, 1) (Line: 50) Drupal\Core\StackMiddleware\NegotiationMiddleware->handle(Object, 1, 1) (Line: 23) Stack\StackedHttpKernel->handle(Object, 1, 1) (Line: 649) Drupal\Core\DrupalKernel->handle(Object) (Line: 19)


Also get a rather large error on the report page that starts with the following - not sure if this info will help or not.

Notice: Undefined index: id in Drupal\Core\Config\Entity\Query\Query->Drupal\Core\Config\Entity\Query{closure}() (line 92 of core/lib/Drupal/Core/Config/Entity/Query/Query.php). Drupal\Core\Config\Entity\Query\Query->Drupal\Core\Config\Entity\Query{closure}(Array, Array) uasort(Array, Object) (Line: 93) Drupal\Core\Config\Entity\Query\Query->execute() (Line: 98)

Update: Solved - it was an issue with the group module when trying to update to 8.2.0-beta2 or above. It was since been resolved from within the module and smooth sailing has returned.

closed as too broad by Clive Sep 19 '16 at 8:14

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Sorry but it's not possible to debug your site from here – Clive Sep 19 '16 at 8:14
  • No worries - I'll edit it to the smaller error I'm currently only getting on my views admin page. It may possibly be responsible for the other issues as well. – W0LF Sep 20 '16 at 0:31

Browse other questions tagged or ask your own question.