0

After numerous problems on a certain website I tried a bare bones fresh install of drupal 7.5 on a subdomain with nothing but the medial library and its dependencies as well as all modules required to put the media library in the CKeditor and what I got was a brand new media library failure not yet seen...

enter image description here

Anyone know why the modal popup repeats the results view multiple times? 3 to be exact but you can only see 2 in this image. I followed the instructions on all components to get this far but the never ending failure of drupal continues to plague me.

update

I hadn't noticed before because of the baffling behavior, but it turns out I can't even select media from any of these repeating views. If I click one and hit submit it just returns me to the node, not updated. Right inside the modal box.

Another note, the views for media library include 3 different views - "media browser" "my files" and "media library" and if I disable any of them they do indeed disappear from the popup, which I could live with if any of the remaining views actually did anything. I applaud the champions who wrote this.

Final Update

With Kevin's help we figured it out. Basically we had to run with wysiwyg module, and use the manual install of ckeditor v 3.5.3 - between those 2 and all the configurations standard to drupal the wysiwyg media library finally works. I guess this makes sense since drupal 8 came out some people may have just not cared to keep the 7x modules stable. Or maybe I'm an idiot and following the step by step instructions on the latest media library module for 7x was just too complicated... but for all of us stuck in the nightmare of drupal, here's one option.

  • Are you getting any browser console javascript errors? – Kevin Sep 23 '16 at 0:49
  • No errors. Actually the behavior is much worse than I described. I'll update the question – Kai Qing Sep 23 '16 at 0:58
  • Are you using CKEditor module, or WYSIWYG module with CKEditor enabled? In 7.x it is honestly such a mess of a setup. – Kevin Sep 23 '16 at 1:00
  • Just CKEditor. It looked like it was one or the other and the recommendations were to not use the wysiwyg module. – Kai Qing Sep 23 '16 at 1:02
  • I've only been able to get it working with WYSIWYG dev build and CKEditor 4.x. The standalone module never worked for me. – Kevin Sep 23 '16 at 1:02
0

This is a shot in the dark, but are you running jQuery Update module? If not, you should give it a try and set the admin area to use jQuery 1.7. Drupal 7 core shipped with jQuery 1.4, and some modules evolved to needing a newer version of jQuery. jQuery Update will solve that for you.

https://www.drupal.org/project/jquery_update

  • I was not, however, after installing and setting it to any higher version it still performs the same way. No console errors – Kai Qing Sep 23 '16 at 0:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.