0

I'm having issues with Clean-URLs not working on my staged server, possibly stemming from the fact that the installation is pulled down from a Git repo, for staging.

I suppose the .htaccess file is configured properly for my local installation, but not for the staged one which has a different file path. (http://drupal.org/node/1018346)

I have my drupal installation on my staged server (which is having the clean URLs problem) in this location:

/home/user/drupal_dev/www

And in my web server's /var directory, I set a symlink pointing to that www directory in my home. That way I don't have to worry about copying files into a root directory that requires sudo.

Can you offer suggestions on what my .htaccess file should look like, in regards to RewriteBase?

  • Figured out the problem was actually related to Apache Rewrite_Module was not enabled on my Ubuntu installation. – David Csonka Feb 3 '12 at 21:40
3

Unless you are running in a subcdirectory (eg, http://www.whatever.com/sub/directory/that/has/drupal/), you should use

RewriteBase /

RewriteBase is really used when you are doing rewrites from a directory that doesn't match your DocumentRoot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.