0

OK, so I have a weird one that I have never seen before. I have about 15 Drupal sites setup locally that are all running fine. I am attempting to setup a new one that I am setting up from a Drush archive dump that was given to me. I have used this method plenty of times in the past.

I am on a Windows 7 box and am running WAMP server v2.5. Apache v2.4.9, PHP5.5.12 and MySQl 5.6.17. So, I create the database, create the entry in my HOSTS file and create the entry in my Apache httpd-vhosts.conf file. I tweak my settings.php file with the correct dB connection info and attempt to go to the site and the site comes up just fine.

I can view the homepage. If I attempt to go to something like local.mysite.com/admin, I get "Access Denied" as expected. However, if I go to local.mysite.com/user and then login with user 1, I get "This site can’t be reached - ERR_CONNECTION_RESET" in Chrome and then I continue to get that even if I attempt to go to the homepage again. If I go to local.mysite.com/user/logout, it will successfully log me out and then the home page comes up again just fine. It only won't display when I login.

I thought maybe it was the temp directory, but I used Drush to check what that was set at and made sure I had that on my local box. I checked the PHP logs, the Apache logs and the MySQl logs and nothing jumped out at me as out of the ordinary. I also checked to make sure the .htaccess files were in place. I also checked this in multiple browsers and got the same result. I also tried changing the name of the site from local.mysite.com to "foo" in my HOSTS file and in Apache and restarted Apache and the site comes up, but it does the same exact thing. The site cant be reached as soon as I login. I'm at a total loss here.

4
  • If you swap/import the database of another known working Drupal site database backup, do you still have these issues? – No Sssweat Sep 27 '16 at 23:13
  • OK so even weirder. I took a database from one of my other Drupal installs that I knew was on the same version of Drupal. I imported it into this site. I did a drush cc all and went to the site. I got the homepage fine and this time I was even able to login, BUT if I attempt to go to ANYTHING in the admin, I get the "This site cant be reached" message. Basically anything in local.mysite.com/admin/*. I can browse the rest of the site fine and see all of the other pages and content within the site, I just can't go to any admin pages. – Erich H. Sep 28 '16 at 18:15
  • I'm wondering if this has anything to do with the fact that this was specifically a Drush archive dump? I've never had issues with that in the past but maybe I will have my guy manually zip up the directory contents and do a manual SQL dump of the dB and see if that changes anything. ??? – Erich H. Sep 28 '16 at 18:19
  • OK I received a manual tar of the root directory and a manual SQL dump of the dB and am experiencing the same exact thing. I login and then the site will not display. – Erich H. Sep 28 '16 at 21:11
0

Couple things you can try.

  1. Clear the session table, as it sounds like there may be some preexisting sessions left over from the archive.
  2. Clear the cache tables as well
  3. Make sure the folders/files are owned by the Apache user
1
  • I cleared the session table and I cleared the cache tables to no avail. I'm on a Windows box, so not sure how to make Apache the owner of the folders/files. I'm assuming Apache must already be using the appropriate Windows account to access the files? – Erich H. Sep 28 '16 at 18:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.