0

I just uploaded a new website to a one.com hosting. From the start I had some trouble with the .htaccess file, after I was finally able to get everything to work, I ran into another problem.

None of the images appear to be loading, when I browse directly to an image, I get this message

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

My .htaccess file is the default one with clean urls enabled.

1
  • As it turns out, there is another .htaccess file located in sites/default/files. This was causing some problems, after removing that everything worked fine again.
    – woutr_be
    Feb 4, 2012 at 14:22

3 Answers 3

3

An .htaccess can cause Internal Server Errors that are unrelated to PHP. Bad directives in the file (eg, syntax errors) and using restricted directives (eg, doing an Option + that has been denied by the main Apache configuration) are two likely culprits. I see the later very frequently with shared hosting.

The only way to really debug this is to find the Apache error log. This varies from system to system. On my CentOS machines, they are at

/var/logs/httpd/error_log

If this isn't your location, do a find error_log to track it down. You may need to be root to read this file.

0

Internal server error shouldn't have anything to do with .htaccess. It's the kind of error that happens when PHP (what Drupal is built on) comes across an error so bad, that it can't continue executing.

It's hard to say what's going wrong, but you should be able to see a hint in your web server's (most likely Apache) error log.

5
  • That sounds very strange, it only happens when I try to access an image directly. The website itself is working perfectly, only images are not loading. I think if there was a very bad error, my entire site wouldn't work
    – woutr_be
    Feb 4, 2012 at 14:14
  • Also, it's a static image, it's not executing any PHP code. Could you explain why that would happen?
    – woutr_be
    Feb 4, 2012 at 14:18
  • As it turns out, there is another .htaccess file located in sites/default/files. This was causing some problems, after removing that everything worked fine again.
    – woutr_be
    Feb 4, 2012 at 14:22
  • @woutr_be if that's fixed it please post it as the answer and accept it so future visitors to this question will know :)
    – Clive
    Feb 4, 2012 at 14:34
  • I don't have enough points to post answers on my own question.
    – woutr_be
    Feb 4, 2012 at 17:56
0

In the .htacsess put before Options +FollowSymLinks a #. It should be #Options +FollowSymLinks

Not the answer you're looking for? Browse other questions tagged or ask your own question.