0

I'm trying to Run the Test from Administrative User, and it bring me below Error message:

An AJAX HTTP error occurred. HTTP Result Code: 200 Debugging information follows. Path: /drupal7.50/batch?render=overlay&id=18&op=do StatusText: OK ResponseText: Fatal error: Maximum execution time of 30 seconds exceeded in C:\xampp\htdocs\drupal7.50\includes\database\database.inc on line 2204

How can I fix that?

1

Increase your PHP max_execution time in php.ini

1

If you check the message after ResponseText, it says:

ResponseText: Fatal error: Maximum execution time of 30 seconds exceeded in C:\xampp\htdocs\drupal7.50\includes\database\database.inc on line 2204

Which means the process has taken more than default execution time set for PHP which is 30 seconds. You can increase the execution time by editing php.ini file located at "C:\xampp\php\php.ini" and setting value of max_execution_time variable to more than 30. And then restart Apache.

The above change will be applicable to all site running from your local. To make it specific to particular site you can use one of the following method:

By editing settings.php located at "sites/default/settings.php" and adding following line:

ini_set('max_execution_time', 120);

Or you can also modify .htaccess file located in your Drupal root and add following line:

php_value max_execution_time 120
0

You can try to change the value for max_execution_time in php.ini file to be bigger than 60. for example: max_execution_time = 300

Do not forget to restart your server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.