1

I have defined several content types, paragraphs, and views for these content types and the idea was to define different features to export and import these content types. I had defined different features for each content type but when I tried to install on a site the Core feature there were a lot of dependencies unmet.

Although is not ideal, I tried to export everything in just one feature, but when I installed it again more dependencies were met. For blocks, fields and paragraphs. Trying to find out what the problem was I opened one of the yml files: field.field.node.producto.body.yml and one of the dependencies is - node.type.producto and this is a content type that doesn't exist but in theory is included in the feature.

This is the message that appears when I try to install the feature:

Incapaz de instalar All, block.block.lemonadmin_views_block__servicios_block_servicios, block.block.views_block__servicios_block_servicios, block.block.web_views_block__servicios_block_servicios, core.base_field_override.node.producto.promote, core.base_field_override.node.producto.title, core.entity_form_display.node.producto.default, core.entity_view_display.node.article.teaser_2, core.entity_view_display.node.producto.default, core.entity_view_display.node.producto.teaser, core.entity_view_display.node.proyecto.teaser, core.entity_view_display.node.team.default, core.entity_view_display.node.team.teaser, core.entity_view_display.node.team.teaser_2, core.entity_view_display.paragraph.card.default, core.entity_view_display.paragraph.foto.default, core.entity_view_display.paragraph.photo_banner.default, core.entity_view_display.paragraph.texto_con_foto.default, field.field.node.producto.body, field.field.node.producto.field_content_en_bloques_product, field.field.node.producto.field_texto_thumbnail, field.field.node.producto.field_thumbnail_producto, field.field.node.producto.field_tipo_de_producto, field.field.paragraph.foto.field_formato_imagen, field.field.paragraph.texto_con_foto.field_formato_imagen, language.content_settings.node.producto tiene dependencias no encontradas.

With Drupal 7 it was really easy to import Features, what steps should I follow to achieve what I want? I'm getting mad with this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.