1

I've added the page.tpl.php and the theme.api.php file to my bootstrap subtheme's template folder, refeshed and everything was fine.

I added <h1>TEST</h1> to the page.tpl.php to check where it would show up. Moved it a bit until I was satisfied where it was.

However I changed my mind and deleted the files in the template folder and got the WSOD...

The two files are still in the original folder and adding them back to the templates folder does nothing.

Is there a way to fix this? Right now the whole site is blank and no errors show up.

Checking the watchdog table leads me to this function:

// Use a default value if $message is not set.
  if (empty($message)) {
    // The exception message is run through check_plain() by _drupal_decode_exception().
    $message = '%type: !message in %function (line %line of %file).';
  }
  • 1
    I do not know the exact answer, but put those files at the place where it was like previous setting. Then using Drush clear cache. – CodeNext Oct 9 '16 at 18:26
  • I am unable to because the site running an a shared hosting server (to avoid migrating the site) and I do not have the rights to do so... – David Oct 9 '16 at 18:36
  • 2
    You need to either look in your php logs or look at the variables inside the watchdog table to see the actual error, without it nobody can really help you. – googletorp Oct 9 '16 at 18:37
1

Clearing the caching tables did the trick! Thanks CodeNext!

However I could not use Drush, so I cleared them manually in PHPmyAdmin using this post

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.