2

I have an email sent by Rules. Here is the text of the email in the Rules action:

Welcome to x! As a professional user, you can now showcase your business on x by creating a Professional Profile and uploading photos of your best x.

Here is what the user gets (note line breaks):

Welcome to x! As a professional user, you can now showcase your
business
on x by creating a Professional Profile and uploading photos of your
best x.

I'm not sure why there are arbitrary line breaks being inserted in the text when sent via email. I've excluded the RTE on email field in the rule, and included only plain text.

  • It's possible the actual text being stored as a \r\n somewhere in it. Try retyping the text (no copy and paste). – kylex Feb 6 '12 at 20:00
  • @kylex - Thanks for your note. I retyped the message and confirmed the issue persists. – Justin Feb 6 '12 at 20:33
5

You are most likely up against the hard limit of line length (77) for plain text emails, defined in a Drupal core function _drupal_wrap_mail_line. It quotes RFC 3676 as the reason for this.

If you want the one line of text you might be able to do it using a HTML formatted email rather than plain text. Alternatively you may want to reformat your email so it suits the available width. The third option of altering core or making a plugin to let you make long lined emails is probably a little overboard.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.