1

I am having an issue where my Drupal 7 Search (Custom search installed and enabled) isn't returning all of the results I'd expect it to.

Here is some background...

  • I'm running Drupal 7 on this site.
  • I have roughly 10 content types, but the search only returns 2 content types – work and blog.
  • I am using the core search module along with drupal custom search module.

The Issue:

When I perform a search I am presented with a selection of results from both work and blog content types. However, the issue is while the blog content type produces the expected results pulling from keywords in both the node titles as well as the nodes body content, the work content type only returns results where the keyword is found in the node title.

Attempted fixes:

  • I have confirmed that the site is 100% indexed. Just in case I have re-built the index.
  • I went to the Custom Search Module settings to confirm that -Any- is being used in the -Any content type- text field. In addition, in the Content exclusion area I've made sure both the blog and work content types were left unchecked.
  • I have confirmed that the Minimum word length to index is at 3. My searched words are above 5.
  • And lastly, two thoughts I didn't know played into the search results, but were worth looking into are the Manage Display settings for both content types under their Search index and Search result highlighting input tabs. Both of which seem to be identical. So I assume wth my limited knowledge of Drupal's configurations isn't really vital to this issue.

I'm still trying other suggestions found here in StackOverflow and will update this as I come across new options to try as attempted fixes.

If anyone has come across this matter and can lead their considerable knowledge on it, that too is always appreciated.

Thanks in advance!

1

Okay, so I was able to resolve this issue through a combination the following efforts.

  • Under both content types and added in new fields to search index and search results highlighting input.
  • Under Administrator/Configuration/Search and Metadata/Search Settings I turned off Simple CJK handling.
  • Under Custom Search Content Tab I used the default of -Any- and under the Exclusion options left all but my two desired content types checked.
  • Under Administrator/Configuration/Search and Metadata/Search Settings I clicked re-index site.
  • I then flushed all caches and ran cron until the site was once again 100% indexed.

After all that I performed my tests again and everything was coming up as expected. Hopefully this can help others later in their testing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.