2

I changed the Acquia Dev Desktop configuration, then when Apache web server and MySQL were restarting MySQL never got back online.

I have enabled the debug option in Acquia Dev Desktop. The logs don't show any clues:

  • /Applications/DevDesktop/piscript.log
  • /Applications/DevDesktop/mysql/data/mysql.err

Workaround

I am using the MAMP mysql in the meanwhile, it has this convenient shell script:

/Applications/MAMP/bin/startMysql.sh

  • I changed the Acquia Dev Desktop configuration What did you change? Did changing it back not fix the problem? We're gong to need more details – Clive Oct 19 '16 at 18:26
  • I changed the port of the web server to 80. My current configuration is apache on port 80 and mysql on port 33070 (I tried changing this, but it hasn't work) – Cesar Moore Oct 19 '16 at 18:46
3

Manually starting the MySQL server:

/Applications/DevDesktop/mysql/bin/mysqld --defaults-file=/Applications/DevDesktop/mysql/my.cnf

Viewing the log:

tail -50 /Applications/DevDesktop/mysql/data/mysql.err

If everything went right you should see the MySQL green dot in the Acquia Dev Desktop GUI.

1

After spending time on searching for the solution. Below solution worked for me.

Open my.ini (my.cnf on linux-based systems and Mac)

Look for [mysqld]

Just below [mysqld] insert innodb_force_recovery = 1

Start MySQL Service

Stop MySQL Service

Remove the line from my.ini (innodb_force_recovery = 1)

Start MySQL Service

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.