Custom displays are no longer showing up on the Front-End; instead only the default view is showing. The following message displays next to the template section on the display page (structure/types/manage/contenttype/display/display_name) "This layout is defined in code: disable layout." When I click "Disable Layout" link it takes me to a new page and displays: "This operation is not possible." What does this error mean? What is the cause? How can it be corrected?

It is not clear whether this error is the reason the display is not showing on the frontend. I have tried accessing the display several different ways include through a view, shows the default (view-mode-full) content display, not the one it is set to. Though the default view is picking up my assigned custom classes.

It is as if Display Suite will not display more than one display on front-end. I can customize and edit "full content" display but this displays on front-end regardless.

  • Is this Drupal 8?
    – argiepiano
    Oct 26, 2016 at 12:38
  • Latest version of DS and Drupal 7.5.1
    – Sam
    Oct 26, 2016 at 14:29
  • All layouts that come with Display Suite are "defined in code". All these layouts will display the message "This operation is not possible" if you try to disable them. This is not the cause of your error. The fact that the front end is not displaying your custom display is due to another problem. You need to include more information if you want me to try to help. For example, how do you generate your front end? With Views? Blocks? Or simply displaying nodes? A screenshot of the Field UI of the content type may also help.
    – argiepiano
    Oct 26, 2016 at 23:34
  • @argiepiano I updated original question with more details.
    – Sam
    Oct 27, 2016 at 3:12

1 Answer 1


It was caused by a conflict with View Role Per Node Module Even though I did not have any node views assigned based on role, it still seemed to be interfering with the Display Suite behavior.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.