I have a text area with CKEditor. The default font in this text area and my theme is 20 pixels and I cannot change its size with CSS, but if I change theme and use Garland, the font change to the normal size.

If I copy Garland styles and page.tpl.php in my theme, the text area is still using a 20 pixels font. Why?

1 Answer 1


CKEditor set its own CSS classes for text areas, but that would not explain why copying the CSS files from a theme to another doesn't change the visualized styles.

The problem here is that simply changing the files used by a theme doesn't change the used styles; you need to let Drupal know the theme has been changed, and this can be done in two ways:

  • you select a different theme as default one, disable the theme you modified, re-enable it, and select it again as default theme
  • you force Drupal to refresh the cache it is using, or you empty the cache tables

In the first case, you submit the theme selection form after each operations.

  • thank u for edit my question :) and your response. i tried two resolution but it didnt work.
    – user780
    Apr 12, 2011 at 9:39
  • thank u. problem was with cache. and this code help me too .cke_show_borders { background:white; font-size:12px; }
    – user780
    Apr 16, 2011 at 8:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.