2

I tried to upgrade from version 8.0.x to 8.1.x. I used drush with the command drush up drupal.

The output shows some errors:

Do you wish to run all pending updates? (y/n): y
The "block_visibility_group" entity type does not exist.                                                                                                                                                                                                  [error]
Performing system_update_8200                                                                                                                                                                                                                             [ok]
Performing block_content_update_8003                                                                                                                                                                                                                      [ok]
Performing path_update_8200                                                                                                                                                                                                                               [ok]
Performing views_update_8200                                                                                                                                                                                                                              [ok]
PHP Fatal error:  Uncaught Error: Class name must be a valid object or a string in /Applications/MAMP/htdocs/drupal8.com/core/modules/field/src/FieldStorageConfigStorage.php:155
Stack trace:
#0 /Applications/MAMP/htdocs/drupal8.com/core/lib/Drupal/Core/Config/Entity/ConfigEntityStorage.php(189): Drupal\field\FieldStorageConfigStorage->mapFromStorageRecords(Array, Array)
#1 /Applications/MAMP/htdocs/drupal8.com/core/lib/Drupal/Core/Entity/EntityStorageBase.php(242): Drupal\Core\Config\Entity\ConfigEntityStorage->doLoadMultiple(Array)
#2 /Applications/MAMP/htdocs/drupal8.com/core/lib/Drupal/Core/Entity/Entity.php(507): Drupal\Core\Entity\EntityStorageBase->loadMultiple(Array)
#3 /Applications/MAMP/htdocs/drupal8.com/core/modules/field/field.module(181): Drupal\Core\Entity\Entity::loadMultiple(Array)
#4 [internal function]: field_entity_field_storage_info(Object(Drupal\Core\Entity\ContentEntityType))
#5 /Applications/MAMP/htdocs/drupal8 in /Applications/MAMP/htdocs/drupal8.com/core/modules/field/src/FieldStorageConfigStorage.php on line 155

After the update I just keep getting the following error on all pages:

The website encountered an unexpected error. Please try again later.

Drupal\Component\Plugin\Exception\PluginNotFoundException: The "page_variant" entity type does not exist. in Drupal\Core\Entity\EntityTypeManager->getDefinition() (line 133 of core/lib/Drupal/Core/Entity/EntityTypeManager.php).

I know this has something to do with the page_manager module. But actually I'm a bit helpless what I can try to resolve this problem. I even have no clue why this problem does occur. The page_manager module is still in the /modules folder.

  • Did you run through the update process for Drupal? – mradcliffe Oct 25 '16 at 19:01
  • 1
    @mradcliffe I can't call the /update.php because I get the same error. – TiMESPLiNTER Oct 25 '16 at 19:02
  • @mradcliffe actually for the /update.php I now get The website encountered an unexpected error. Please try again later. Error: Class name must be a valid object or a string in Drupal\field\FieldStorageConfigStorage->mapFromStorageRecords() (line 155 of core/modules/field/src/FieldStorageConfigStorage.php). – TiMESPLiNTER Oct 25 '16 at 20:02
2

That means you have a field with an unknown field type. Are you sure that you're not missing any modules that you used to have installed? And the the missing entity type sounds like you used to use https://www.drupal.org/project/block_visibility_groups but now it's gone?

My guess is that you accidently removed all/some contrib modules before updating, which you shouldn't do. Minor updates are like any other normal core update, except they come with some more changes.

  • The module and its files is still located under /modules however there is a no block_visbility_group/config/install folder... could that be a problem? But I can't image how this dir could get lost because I didn't touch the /modules folder at all. – TiMESPLiNTER Oct 25 '16 at 20:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.