0

I installed Simplenews 8.x-1.0-alpha2 using /admin/modules/install and then pasting the url to the tar file.

Now I want to uninstall/delete it, but I cannot find where the folder is.

I have checked in /modules and /core/modules

I even tried uploading the dev version to the /modules folder, but it does not ask me to overwrite.

This is so strange, where else could it be?

Update

I tried as suggested by sanzante using Devel and echo drupal_get_path('module', 'simplenews')

it says modules/simplenews

enter image description here

but when I try to go there with FileZilla, it does not let me. I also re-started FileZilla multiple times.

enter image description here

  • If you have shell access you can locate it using find executable: find /path/drupal/root -type d -name simplenews – sanzante Oct 28 '16 at 15:46
  • @sanzante sadly I do not – No Sssweat Oct 28 '16 at 15:51
  • 1
    @NoSssweat it seems that the FTP servers is unable to get the actual file listing of the modules dir so it denies access to simplenews module. Double check file permissions (simplenews was installed using Drupal so it may have different permissions or owner than the rest of modules) and try to restart FTP server. – sanzante Oct 28 '16 at 16:46
  • 1
    ok, good enough. Then I bet (also?) it is some file permission issue, whereas at least your Filezilla userid "pttv" (shown upper left in Filezilla screenprint) does not have read access to the SimpleNews module dir. And if you can't see it, you can'"t delete it, right? Time to get some root-user involved to go check the owner, group, etc of the simpleNews dir? – Pierre.Vriens Oct 28 '16 at 16:53
  • 2
    @NoSssweat, no, Drupal 8 still supports modules in sites/all/** per ExtensionDiscovery::scan. It was a possibility since the question did not have many details about the site install when I commented. – mradcliffe Oct 28 '16 at 17:19
1

Turns out that his site was moved to another server.

The FTP that I was seeing was from the old server. When I installed the simplenews it got installed in the new server.

  • 4
    Too bad this question was not asked on an April 1st ... !!! – Pierre.Vriens Nov 1 '16 at 8:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.