1

I had a previous error with the Address module, here. Unfortunately the solution is no longer helping.

I'm installing the Address module as follows:

composer config repositories.drupal composer https://packages.drupal.org/8
composer require "drupal/address ~1.0"

Unfortunately I get the following error:

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested package commerceguys/addressing (locked at v0.8.4, required as ~1.0) is satisfiable by commerceguys/addressing[v0.8.4] but these conflict with your requirements or minimum-stability.
  Problem 2
    - The requested package commerceguys/zone (locked at v0.7.1, required as ~1.0) is satisfiable by commerceguys/zone[v0.7.1] but these conflict with your requirements or minimum-stability.

I've tried the solution linked above, but it doesn't help. I've also checked I'm running the latest version of Composer (1.2.1).

Any ideas?

James

  • The error message says the locked version is lower than the version you are requiring. I would try removing the composer.lock file, and running composer require "drupal/address ~1.0". Keep in mind that you could get some problems, with packages.drupal.org. I tried using it for a local site, and the modules with dependencies ended up to be installed on the vendor directory, instead of the modules directory. – kiamlaluno Nov 3 '16 at 9:58
0

The problem seems to be that I had installed a previous version of the Address module in the sites/all/modules directory, which seems to have been confusing Composer. Composer installs into the modules directory, and after deleting the older copy, I was able to run the composer require command without problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.