1

How do I Display empty fields in Views? Empty_Fields module does not work for me as there needs to be a custom text for it to display.

I want to display all labels even if the fields are empty. How do i achieve this?

Thanks

1 Answer 1

0

In Views field settings add   to No results behavior. Your View will then display a space and a field label if the field is empty.

enter image description here


If you're using Unformatted list format for your View block, then in Format -> Fields -> Settings make sure that Hide empty fields checkbox is unchecked. See screenshots below.

enter image description here

enter image description here

9
  • Hi, Thanks for the tip oksana-c. I tried that, it still doesn't display the fields. Anything else that I can try? Commented Nov 5, 2016 at 19:15
  • @GirishCholayill You can try adding <br/> instead of &nbsp;. If that doesn't work - you'll need to provide more info on how your View fields are configured.
    – oksana-c
    Commented Nov 5, 2016 at 19:19
  • tried that, still no go. Basically what I am trying to achieve is, I have a custom Module of contacts with many fields. I am creating a custom node view using either Panels or Views (Created view blocks of certain specific fields) to get a custom look. All fields in the custom Contact module don't have values. Some of them need to be input by the user when updating. A user may not know this field exists unless and until they try to edit the Contact Node. I want to display these empty fields for the user to see. While using either Panels or Views, these fields remain hidden. Commented Nov 5, 2016 at 19:26
  • @GirishCholayill see updates above.
    – oksana-c
    Commented Nov 5, 2016 at 19:39
  • Yes, it is in Unformatted list and the Hide Empty Fields is also unchecked. Commented Nov 5, 2016 at 19:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.