0

I successfully migrated a Drupal site I'd been working on to my local machine. The site itself and its content are all fine, but when I login as administrator, the admin toolbar is an unstyled list, as seen here.

I seem to have the same problem as described in this other thread; however, I have tried the solution suggested with no success.

All the permissions are correct, either 755 (folders) 644(files), and I did a recursive chown on the entire directory. I flushed the caches before I migrated the site and then again when I got it live locally. I am using the admin toolbar module, so I tried uninstalling, no change, and reinstalling, no change.

If I observer the console output from web browser, when I log in as admin, I get the following:

The stylesheet http://localhost/drupal/?og6o9k was not loaded because its MIME type, “text/html”, is not “text/css”.

SyntaxError: expected expression, got '<'

I don't know if these are related, but they are the only noticeable difference when I log in as admin, so I'm acting as if they are related.

0

Have you tried turning off CSS aggregation and seeing what happens?

The fact that it's trying to load a stylesheet at "http://localhost/drupal/?og6o9k" makes me think it's an issue with how your public file system is setup. Like it tried to create a CSS file but failed. I would check which folder it's set to and make sure the permissions are correct.

It could also be an issue with the theme. Trying switching to another theme temporarily and see if that fixes things.

Lastly, you can try uninstalling and reinstalling a fresh version of Admin Menu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.