1

I have some problems with files. Everyone is talking about admin/content/file, but I just don't have the link under /admin/content, and going to the url by hand returns me to admin/content.

I seem to be pretty much up to date (drupal 7.50, file_entity 7.x-1.5) and media is working (it's just buggy in strange ways).

Where should I look to find why the link is not showing under /admin/content ? Iow, who should be providing the view ? That would give me a clue.

enter image description here

3
  • Have you cleared Drupal Cache and checked File Entity user permission if they are set to right roles.?
    – sarathkm
    Nov 7, 2016 at 12:34
  • Yes cache. There is no 'permissions' link next to the module in /admin/modules, and File Entity has no specific box of settings under /people/permissions (should it?). Clicking on 'configure' for the module takes me to /admin/config/media/file-types.
    – commonpike
    Nov 7, 2016 at 13:08
  • Hmmm .. File Entity seems to be part of the 7.x-1.x branch of Media. I would prefer not to update to the 7.x-2.x branch just yet.
    – commonpike
    Nov 7, 2016 at 13:13

1 Answer 1

1

You have to install and enable the File Entity (fieldable files) module:

https://www.drupal.org/project/file_entity

7.x-2.12 works flawlessly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.