I tried to install CKEditor Font Size and Family on my fresh Drupal 8 install, but both buttons does not seem to show up.

  1. Plugin is placed in /libraries
  2. CKEditor and CKEditor Font modules are both activated
  3. Both buttons S and F appear when I edit my content format (Full HTML)
  4. Both buttons were added to the Full HTML CKEditor toolbar
  5. My content use Full HTML format, and I am administrator
  6. But these buttons does not appear when I edit my content

This problem is still here after a few days of development, so I'm already sure it's not cache-related.

Did I miss something in my configuration?

  • Did you ever find a solution to this? Commented Jul 31, 2017 at 13:18
  • Unfortunetally, no. I've been struggling with this for hours without success ; it works perfectly on the production server, and I cannot understand the difference with the dev server, so I gave up, sorry.
    – zessx
    Commented Jul 31, 2017 at 13:31
  • Is it possible that your "Allowed HTML tags" are not synced with the dev server? Commented Jul 31, 2017 at 13:53

1 Answer 1


For me, I put the center, left, and right align buttons in my "TOOLBAR CONFIGURATION". But You also need to add the class attribute to the filter to "Allowed HTML tags" at the bottom of the page.

<p id class> <br> <u> <s> <em> <strong> <cite> <blockquote cite> <code> <ul class type> <ol class start type> <li class> <dl> <dt> <dd> <h2 id> <h3 id> <h4 id> <h5 id> <h6 id> <drupal-entity data-entity-type data-entity-uuid data-entity-embed-display data-entity-embed-display-settings data-align data-caption data-embed-button> <img src alt data-entity-type data-entity-uuid data-align data-caption> <a class href hreflang !href id rel target title> <table> <iframe src frameborder width height scrolling allowfullscreen> <caption> <tbody> <thead> <tfoot> <th> <td> <tr>
  • 1
    Nice catch! This indeed fix the issue, many thanks.
    – zessx
    Commented Jul 31, 2017 at 14:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.