0

I am trying to create a copy of a Drupal installation in a different folder.

I want to copy the site that is located on https://my-url/drupal to http://my-url/copy. I copied all the files in the Drupal root to the copy folder and I exported and imported the database in a new database and also changed the database configuration of the copy site using settings.php (copy/sites/default/settings.php).

When I put the main site on maintenance mode though the copy site is also put on maintenance mode.

Am I missing something here?

  • you check both settings.php file once again. – DRUPWAY Nov 15 '16 at 16:20
  • hehe...yeap that will work most of times but not this one. The two files are showing a different db as they should. I am breaking my head here. – pierostz Nov 15 '16 at 16:26
  • 1
    Make sure they're not sharing cache bins (memcache/redis/etc) – Clive Nov 15 '16 at 18:17
  • Also check that the RewriteBase line in .htaccess file is pointing to the correct directory in each installation. – juankvillegas Nov 16 '16 at 2:05
  • @Clive spot on with your suggestion. I will answer this question with the steps I took...thanks for your help. – pierostz Nov 16 '16 at 14:54
0

Thanks to @Clive giving me an indication that is something to do with memchache I followed these steps to resolve my issue.

  1. Disabled the memcache module.
  2. Commented out the memchache configuation settings in the settings.php of the copy site.

This resolves the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.