I have enabled the boost module. It creates a folder till "cache/normal/example.com". But there is no cached html files.

I am struggling with this, any help?


Without any further information, I would check the permissions on your directories. In my D7 install, I don't have a 'cache' directory, so it looks like it will need to be created either by Boost itself or by you manually.

Try this on your web server as root user:

mkdir -p $DRUPAL_INSTALL/cache/normal
chmod 755 -Rv $DRUPAL_INSTALL/cache

The above will create your 'cache/normal' directory in the drupal root (where index.php is). Then it transfers ownership of these directories to the web user, assuming apache here. Finally it corrects the permissions.

Be sure to modify the $DRUPAL_INSTALL and $WEB_USER variables to match your web server's environment.

  • i already have cache directory.but the_.html file not creating. i have below direcory "cache/normal/drupal" – udhaya kumar UK Nov 17 '16 at 5:21
  • @udhayakumarUK did you figure it out? What are the permissions set? – rovr138 Nov 18 '16 at 18:16
  • i set permission 777 – udhaya kumar UK Nov 19 '16 at 12:24

If the configuration seems correct, there are still some circumstances, where the page get's not cached by boost.

You can place the boost block (called Boost: Pages cache status - that will show you information about the cached page, or tell you that it won't be cached) on every page to start diggin.

Most common causes can be:

  • PHP execution in a block (php module enabled ..)

Solution would be to create a custom block in a custom module doing that php

  • Authorized user has dependencies on the content shown. The page gets only cached for anonymous users

Solution would be to load that part via AJAX, also consider using authcache, which does that for the most common use cases

  • ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.