2

This question already has an answer here:

I setup a date field for my content type and also have an exposed date filter for my view, but I can't seem to figure out how to get the date picker popup to show up. Is there a setting that I have to set somewhere?

I've also installed Better Exposed Filters and I still don't see any option for my view. Also installed Date and the Calendar module. I know jQuery UI has a built in calendar popup and that's installed by default on Drupal 8 installs.

How do I turn this on?

marked as duplicate by kiamlaluno Jan 12 '17 at 8:43

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

This is usually because the ui.datepicker wasn't added as a dependency in your theme as this isn't usually enabled by default in themes.

I use the seven theme for administration, so I had to add the line:

  - core/jquery.ui.datepicker

Looks like this in my seven.libraries.yml file:

enter image description here

  • This is not strictly correct. See drupal.org/node/2648950 for a better explanation of what is going on. – mpdonadio Nov 20 '16 at 1:33
  • So what did I do wrong? – Patoshi パトシ Nov 20 '16 at 3:29
  • 1
    You didn't do anything wrong. This simply doesn't work yet with just Drupal core. – Berdir Nov 20 '16 at 8:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.