1

I can't access to my site because of this error:

UnexpectedValueException: External URLs do not have an internal route name. in Drupal\Core\Url->getRouteName() (line 554 of C:\Users\user\Documents\Sites\camp\core\lib\Drupal\Core\Url.php).

This is the function that I have in line 552 to 558.

public function getRouteName() {
if ($this->unrouted) {
  throw new \UnexpectedValueException('External URLs do not have an internal route name.');
}

return $this->routeName;
}

The last thing I have done it was update 2 nodes that I have created and a View of that content type.

The nodes I have changed the text (just text, didn't put URL or so) and added a photo storage locally

That content type has 2 fields, body and image

On view I deleted the field body and then added again

I have deleted the view, nodes and content type and I still having that error

I don't know if this help but I have installed these modules:

video embed field, views infinite scroll, superfish, pathauto, libraries, flexslider and entity reference revision.

Today I installed the module paragraphs but I uninstalled after the error

Any ideas?

This is the second time that happened to me with this site, the first time I lost some work because I have backed up an older version, but I don't want to lose some work again.

1

This is a known issue with the superfish-8.x-1.0-rc3 module. Also the rc4 and rc5 versions.

I fixed the problem on Drupal 8.2.1 + superfish-8.x-1.0-rc4 by applying a patch (#15) to superfish.theme.inc

Just upgraded to Drupal 8.2.3 + superfish-8.x-1.0-rc5 and it is still broken, so I reverted back to superfish-8.x-1.0-rc4 + patch 15.

1

Hi

After a lot of research and try and error attempts I have found what was doing that.

My problem starts when I delete some view page that I have created, it seems the path of that page is still "alive".

If I create another page with them same path the site works fine

So to fix this problem:

- Delete the page view with some path, eg "contacts" (at this point I have that error)

- Create a new content and set the same URL name, in this case "contacts" (at this point the site is working 100%)

- Then delete the content created in the step above (site is still working 100%)

This seems the URL path its no deleted by drupal on the first step and thats why I have that error.

0

The error also can appear for other reasons. In my case I had disabled a view, but there was still a manually created menu link pointing to the path of the disabled view. Deleting / disabling the orphaned menu link solved the problem. What was weird is it did not throw the error on every page the menu was on, only the front page in my case.

So check if you changed any paths / menu paths that are still in use.

Not the answer you're looking for? Browse other questions tagged or ask your own question.