0

After downloading fresh files and restoring fresh database from prod website, on my local server (IIS) I have a problem.

Fatal error: Call to undefined function wincache_ucache_get() in E:\XXX\sites\all\modules\wincachedrupal\drupal_win_cache.inc on line 145`

  • Permissions are good (for IUSR and IIS_IUSR)
  • settings.php passwords are OK
  • I updated the wincachedrupal module to newest version
  • I cannot do anything with Drush (same error as above)
  • I cannot rebuild the registry
  • if I delete or change the name of the wincachedrupal module, I get this error:

    Fatal error: require_once(): Failed opening required 'E:\XXX/sites/all/modules/wincachedrupal/drupal_win_cache.inc' (include_path='C:\xampp\php\PEAR') in E:\terma\includes\bootstrap.inc on line 2413`

Have you any idea on what can be wrong?

  • 1
    Reference to that file is located in your settings.php most likely. Remove it and you should be good – mikeytown2 Nov 24 '16 at 5:17
  • Did the suggestion of @mikeytown2 work? – Gun5m0k3 Feb 28 '17 at 9:59
0

I would assume that this is cache related. Try clearing your cache directly on the database by truncating the cache_* tables (since Drush is not working).

You cannot delete modules by removing them from in your modules folder. You have to disable/uninstall the module first, if you cannot disable the module through Drush or UI you can edit the system table by searching the column 'name' for your module and setting the column 'status' to 0. After that clear your cache again.

  • done and the same error. – RustBeard Nov 23 '16 at 11:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.