0

I would like to update drupal core from 8.2.1 to 8.2.3 in a local environment. The normal procedure of deleting both the vendor and core folders along with the files in the site root won't apply. The commerce2.x disto installation puts the vendor folder outside of the site root and it contains more files than in a fresh drupal 8 downloaded vendor folder. I'm guessing there must be a slighty different process.

I run composer update drupal/commerce --with-dependencies.

The image attached shows the error.

If anyone can give me the steps I need to take, that would be great.enter image description here

6
  • Did you check the command line finds the Git executable?
    – apaderno
    Nov 23 '16 at 11:24
  • Thanks for the edit and comment. No i didn't check, how would I get the command prompt to find it or is that the subject for another post?
    – 8en
    Nov 23 '16 at 11:39
  • Open PowerShell and execute git as command. If you still get 'git' is not recognized as an internal or external command, then Powershell doesn't know where to find the Git executable.
    – apaderno
    Nov 23 '16 at 12:32
  • Sorted the git problem, thanks for the pointers. I'll update my original post and remove that section. Thanks
    – 8en
    Nov 23 '16 at 19:56
  • I figured out how to do the core update...doh! Should i remove my original post or leave it?
    – 8en
    Nov 23 '16 at 20:31
0

Simple solution found in the end. Before running a composer command I had to add paths in my Windows Environment path variable to both the Git.exe file and the ssh-agent file.

I then ran a slightly different composer command from the one above: composer update drupal/core --with-dependencies
I did this from the root of my site.

I had to make sure that drupal/core is in the require part of the composer.json file and not the replace part.

This site is temporarily in read only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .