0

I'm new to Drupal and Drush and so am hoping someone can shed some light on this.

I tried to turn on Theme Debug with Drush:

drush vset theme_debug 1

But I keep getting an error I don't entirely understand:

Drush command terminated abnormally due to an unrecoverable error.                                             
Error: Declaration of Drush\Command\DrushInputAdapter::hasParameterOption() must be compatible with
Symfony\Component\Console\Input\InputInterface::hasParameterOption($values, $onlyParams = false) in
phar:///usr/local/bin/drush/lib/Drush/Command/DrushInputAdapter.php, line 27

I tried drush status too and got the same issue, so I think drush is probably broken across the board.

I tried deleting and reinstalling drush and reprovisioning my virtual box to no affect.

Would anyone know what could've gone wrong here?

(I am running Drush 8.1.7. on Drupal 7.5)

  • You try to reinstall the Drush. I guess you have run composer update on Drush folder which downloaded a latest symfony/console package. – Jimmy Ko Nov 24 '16 at 12:55
0

Update drush

composer require drush/drush:9.0.0-alpha1 
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.