I backed up my files and database. uploaded files to new server, created and restored the database to the new server, edited the settings.php file. I navigate to the site, it pops up perfectly. I try to navigate to any other page and I get a 404 page not found error. What am I missing?


Do you have mod_rewrite for Apache enabled/installed? If not, verify this is the case.

Also, ensure that your .htaccess file in your Drupal root is unchanged from the old server.

If you're on a Debian-based distribution, go to /etc/apache2/mods-available to verify that rewrite.load is present. Then go to /etc/apache2/mods-enabled to verify that rewrite.load is symlinked in that directory.

If you're on a RedHat distro like CentOS, then go to /etc/httpd/modules and look for mod_rewrite.so. Then, open up /etc/httpd/conf/httpd.conf and verify that this line is in there LoadModule rewrite_module modules/mod_rewrite.so.

  • how do i verify that? My .htaccess file is exactly the same as before. – J-Fiz Feb 9 '12 at 21:41
  • Is your server debian or redhat-based? – Lester Peabody Feb 9 '12 at 21:42
  • Not sure, I'm using 1and1.com web server. Inside the .htaccess file I appears that mod_rewrite is turned on. – J-Fiz Feb 9 '12 at 21:48
  • So that's not the issue. Are you using clean URLs? – Lester Peabody Feb 9 '12 at 21:49
  • 1
    Something else to check on, it sounds like you don't have access to the Apache VirtualHost configuration... it is imperative that the AllowOverride objective is set so that it picks up your .htaccess settings. – Lester Peabody Feb 9 '12 at 21:57

Do you have the rewrite mode enable? If not, try enabling it.


Create a php.ini file and disable "register_globals" on the 1and1 server.


Have you copied the .htaccess file? Sometimes, it is not copied, because files stating with an . are regarded invisible and non archive

Have you got

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

in your .htaccess?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.