1

I have been transferring a development site to a new computer and ran into a problem when I transferred the local.css file I had been using to style my content. While the file works fine on the old computer it is not working on the new even though the file configuration is identical.

The site is using a subtheme for Stark. Both theme are present and enabled. The general appearance of the site is now consistent with the Stark theme. I am using firebug to determine the css sources. If I select a superfish menu on my site, I get css input from system and superfish.css, but not from local.css. It is not being used at all because I can copy over a setting from superfish and change it in local without affect. My caches are constantly being flushed so that is not the problem.

Here is the directory structure:

  • "example.div/themes/stark/stark.css" - used
  • "example.div/sites/all/libraries/superfish/superfish.css" - used
  • "example.div/sites/all/themes/sub_stark/css/local.css" - not used.

The sub-stark info file reads:

       name=sub stark 
       description = Stark 
       sub-theme base theme = stark 
       core = 7.x 
       engine = phptemplate

       stylesheets[all][] = css/local.css

Configuration looks good. Caches are cleared. Have I forgotten a setting somewhere?

  • Have you tried stylesheets[all][] = css/local.css ? – davidgmar Feb 10 '12 at 17:04
  • Yes, its a typo on this question, there is no space between'][' in the original. But the space should not matter in php. – Ashlar Feb 10 '12 at 17:38
  • 5
    Spaces doesn't matter in PHP, but the .info files are text files parsed using a regular expression, not used as PHP code. See drupal_parse_info_format(). – kiamlaluno Feb 10 '12 at 19:43
  • But that doesn't explain the problem, since there isn't a space in my stylesheets' file address. By moving the file back into the sub_stark directory instead of a css subdirectory it works. I've not seen that problem before with Drupal. – Ashlar Feb 10 '12 at 21:53
  • I tried on my test site, and the CSS was included; Drupal is using @import url("http://tero.local/dr72/sites/all/themes/MiniStark/css/local.css?m74599"); to load it. – kiamlaluno Jul 13 '12 at 19:44
1

Well, I've got it to work by moving the file into the Sub-stark directory instead of a sub directory and changing the .info file. I am working on Windows 7 using an Oracle VM with Ubuntu, so there may be that is causing a problem.

  • Heh, interesting technology stack ;) – David Thomas Sep 12 '13 at 10:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.