1

We are trying to allow Markdown input on long text fields for certain content types. It is proving difficult. Here is what I have done:

  1. Installed Markdown filter module.
  2. Added a new Text Format in Configuration -> Content Authoring -> Text Formats.
  3. Edited the text fields on our "Lesson Plan" content type so that the user can select "Markdown" text format.

That should be everything I have to do, right?


BUT WAIT -- number 2 above is giving me very strange behavior!

  • In my "Markdown" text format configuration page, I can't see the Markdown option unless I first clear all the caches while I am on that page.
  • After I have cleared the cache, the Markdown checkbox shows up, and I can select it.
  • But after hitting "Save Configuration", the option disappears, and none of my content formats correctly when I try to select the Markdown text format.

Why is this happening? I don't know where to start looking!

0
1

I fixed the problem. I don't know why it acted the way it did, but it started working after I deleted the markdown folder in sites/all/modules, and re-installed using the "official" /admin/modules page (which is SSL enabled).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.