1

On Drupal 7.52 and ckeditor module 1.17 (library version 4.6.1) and this is driving me insane. Here's a list of things I've noticed and tried:

  1. Seems to primarily happen with unpublished nodes but not all unpublished nodes seem to have it. I have been testing using account 1 which has all privileges so I doubt it's permission related.
  2. If I refresh the page, I can see the node body show up where ckeditor would be for half a second. When ckeditor loads it's gone though.
  3. Checking the page source I can in fact find the textarea with the entire node body, so it is being sent to the browser.
  4. No errors at all on the browser's console.
  5. Can get in both Chrome and Firefox.
  6. Disabling ckeditor makes the node body viewable again, re-enabling brings me back to the same problems.
  7. Typing something on the empty ckeditor field, going to plain text mode and I can see the HTML, then going back to rich text mode and it's all gone again! This behavior happens when creating new nodes as well, but not with already published nodes that show the node body from the beginning. This also produces no console errors!
  8. Updated ckeditor from 4.5.9 to 4.6.1.

Anyone have any ideas as to things I can test to pinpoint this problem?

  • Test Filtered HTML vs Full HTML. Also, try adding "config.allowedContent=true;" to both portfolios (yoursite.ca/admin/config/content/ckeditor). – Chris Happy Dec 8 '16 at 23:57
  • All my nodes use Full HTML, and some work others don't so I don't think it's that. Switching between the two makes no difference. Adding that to my settings didn't work either :( – eo1919 Dec 9 '16 at 0:45
  • Anything appearing in source? – Chris Happy Dec 9 '16 at 1:29
1

If anyone is ever having this problem, you should check your response headers for requests sent by ckeditor. It will attempt to send a request to /ckeditor/xss to run XSS filters and if that fails it will silently just hide the entire contents of the form. In the response header I noticed a Location parameter that is only available when the form fails. The location parameter was: /user/login?destination=ckeditor/xss. This obviously means that ckeditor's request for the XSS filters is being intercepted by some other module and sending it to the login page.

In my case, the problematic content was unpublished nodes. I have yet to find the exact module causing the redirect for ckeditor, but disabling the XSS scan in includes/ckeditor.utils.js on line 163 worked perfectly to solve all my issues (seen on post #9 here https://www.drupal.org/node/2069871)

|improve this answer|||||
0

I recently had a similar issue, not exactly the same scenario, but pretty close, using Drupal 7.50.

After all sorts of things I tried, and which didn't work, I downgraded the CK Editor library to 3.6.6.1. And sure enough: the issue disappeared. Not really a "fix" IMO, but at least the WYSIWYG editor started working again.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.