4

I have installed the Linkit module to a test site.

I have created a profile, set Matchers and created attributes. I have gone into the CKEditor configuration and chosen my Linkit profile, added the Linkit button, saved the configuration and then liberally cleared the cache on my test site (Vagrant running a lamp stack and Drupal 8.)

When I attempt to use the Linkit feature on either a new piece of content, or an existing one, the dialog box appears with all the desired options, however, other than the standard CKEditor link behaviour none of the other attributes work. I cannot set the title, I cannot set the target attribute.

No errors are appearing in the log and I can find no similar problems on line.

Can anyone suggest a reason this is occurring?

  • 1
    Is the filter not full HTML? If not you may need to allow an a tag to have such attributes. – Kevin Dec 15 '16 at 1:07
  • yup that was it... i'm an idiot. Always check the allowed tags in the CkEditor configuration. It would be nice if they provided an error/auto enabled the tags when you enabled something like linkit. – tanbog Dec 15 '16 at 1:15
  • 1
    I've written a few CKEditor plugin integrations and I still do it from time to time. – Kevin Dec 15 '16 at 2:06
1

If the filter not Full HTML, you will need to edit the filter format and enter the attributes on the anchor tag in the settings. If not, they will be stripped out (for security reasons).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.