3

I'm using drupal 7 and have a view with column edit content link. I want to hide a whole column edit to users and only administrator who can see that column. How can I achieve that without coding since U don't have the permission to access that.

I already tried using Field Permission module but i can't find the solutions either..

2

Set up multiple page views displays with the same path.

You can clone your page views display to accomplish this.

Keep their path settings the same.

In the regular user one, remove the Edit field. Be careful that you are only editing "This page (override)" and NOT "All displays."

In the admin views display, under Page Settings > Access, restrict your admin view to role=admin.

Re-order the views displays so the most restrictive (admin) views display is first.

To reorder the displays, look for the item "edit view name/description" in the upper-right corner of the screen and expand it to select "reorder displays" - this will take you to a screen where you can drag and drop the views displays. After you put yours in the right order, click "Apply" then save your view.

Hope this helps.

  • I follow your instruction, and it only works for anonymous user. For certain roles, still can see the edit column. I already tried setting in Access under Page Settings (for regular page views) and choose the roles. – uchuneno Dec 16 '16 at 9:35
  • I just did a test view and it works fine on my end. What is the Access setting on your non-admin view? I have mine set to Permission | View published content. If you have something else, try changing it to this and see if that helps. Here is a screenshot of my admin-only views display: i.imgur.com/MBCDFx0.png And here is a screenshot of my everyone-else views display: i.imgur.com/EzX6UKf.png – Anne Bonham Dec 16 '16 at 21:37
  • This is my admin settings : imgur.com/7M8m94A and user settings : imgur.com/tCoBcmA. This is the results : Admin-> imgur.com/nkfk81o, Authenticated User-> imgur.com/nrpagX1, & Anonymous User-> imgur.com/nrpagX1. I want view of anonymous is same as authenticated user.. Am i missing something here? – uchuneno Dec 19 '16 at 2:38
  • That's odd: your setting look correct to me. Is it possible these views are being overwritten by a theme template? In other words, do you see a template in your sites/all/themes/yourtheme/template directory that have "view" in their file names? – Anne Bonham Dec 20 '16 at 0:57
  • hey @anne i resolved this with uncheck "bypass views access control" in permission people. Now the edit column is hidden. Thank you for your kindness answer my questions. Cheers – uchuneno Dec 21 '16 at 4:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.