I have zymphonies theme installed in my Drupal 8 website. In my localhost everything was working fine. But when I uploaded the entire files to the remote server the styling of breadcrumbs has gone (it shows as numbered list). As I inspected with the firebug the css file that is taken from default/files/css is different.

There are large number of css files in the default/files/css how does Drupal choose to select a particular css from that set of css files?

The location "default/files/css" is used to store aggregated CSS files, created by Drupal Core. CSS/JS file aggregation can be enabled/disabled by navigating to Drupal Performance settings page, using "Admin => Configure => Development => Performance" and enabling checkbox "Aggregate CSS files". You can also delete the .css files from "default/files/css" directory and Drupal will automatically create new one whenever site is visited first time after that. Check the screenshot below:

Drupal Performance Settings

It is not advisable on production, but if you want to use original files from Theme's CSS directory directly, then uncheck "Aggregate CSS files" setting checkbox and Try clearing cache.

  • Thanks for the reply, I did as you mentioned and cleared all the caches. But still the breadcrumb style is different from what is showing in my local system. I have made sure that themes/theme_name/css/global.css is same in both my local and remote. – Lalas Muathasim Dec 15 '16 at 6:04
  • Ok, Check your page view source (ctrl+u) and try accessing global.css file in browser to make sure the breadcrumb CSS is available. If not try refreshing few times or try in incognito window. – Yogesh Dec 15 '16 at 6:18
  • Ok, in that case, you might need to check template and if required override remote template. – Yogesh Dec 15 '16 at 6:28
  • I have inspected the code and found the rendered template is slightly different each other. The original breadcrumb is rendered as unordered list (within <ul> ) and there is a 'breadcrumb-divider' after each list items. But in the remote server the breadcrumbs are rendered as ordered list and the breadcrumb-divider is also missing – Lalas Muathasim Dec 15 '16 at 6:40
  • Check if your site theme, if it is overriding breadcrumb HTML. This should mostly be inside 'THEME_NAME.theme' file, but check other files as well. The best possible way to search is search using class name "breadcrumb-divider" in entire theme. – Yogesh Dec 15 '16 at 6:43

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.