1

I'm pretty sure I installed Drush 8 correctly on Windows 10. I ran the command window as administrator. I changed to my Drupal directory, but I get "Command pm-update needs a higher bootstrap level to run - you will need to invoke drush from a more functional Drupal environment to run this command. The drush command 'pm-update' could not be executed. Drush was not able to start (bootstrap) the Drupal database. Following are all the messages & commands I entered.

ColorConsole [Version 2.4.2000 ] Microsoft Windows [Version 10.0.14393] (c)        2016 Microsoft Corporation. All rights reserved.
C:\Users\samst\Downloads>cd C:\xampp\htdocs\D8
C:\xampp\htdocs\D8>drush status Drupal version : 8.2.4
Site URI : http://default
Database driver : mysql
Database hostname : localhost
Database port :
Database username : root
Database name : d8
PHP configuration : C:\xampp\php\php.ini
PHP OS : WINNT
Drush script : C:/Users/samst/AppData/Roaming/Composer/vendor/drush/drush/drush.php
Drush version : 8.1.5
Drush temp directory : C:\Users\samst\AppData\Local\Temp
Drush configuration :
Drush alias files :
Drupal root : C:\xampp\htdocs\D8
Drupal Settings File : sites/default/settings.php
Site path : sites/default
Sync config path : sites/default/files/config_zKz1ApBZ7jZluMMX-WwnTZyMM0eVUEH6DkWwb6HxM_V0Y0izLCsKyaGVKs7EDZiAE FFWlaSJ4g/sync
C:\xampp\htdocs\D8>drush drush pm-update The drush command 'drush pm-update' could not be found. Run drush cache-clear drush to clear the [error] commandfile cache if you have installed new extensions. Drush was not able to start (bootstrap) the Drupal database. [error] Hint: This may occur when Drush is trying to: * bootstrap a site that has not been installed or does not have a configured database. In this case you can select another site with a working database setup by specifying the URI to use with the --uri parameter on the command line. See drush topic docs-aliases for details. * connect the database through a socket. The socket file may be wrong or the php-cli may have no access to it in a jailed shell. See http://drupal.org/node/1428638 for details.
Drush was attempting to connect to: Drupal version : 8.2.4
Site URI : http://default
Database driver : mysql
Database hostname : localhost
Database port :
Database username : root
Database name : d8
PHP configuration : C:\xampp\php\php.ini
PHP OS : WINNT
Drush script : C:/Users/samst/AppData/Roaming/Composer/vendor/drush/drush/drush.php
Drush version : 8.1.5
Drush temp directory : C:\Users\samst\AppData\Local\Temp
Drush configuration :
Drush alias files :
Drupal root : C:\xampp\htdocs\D8
Drupal Settings File : sites/default/settings.php
Site path : sites/default
Sync config path : sites/default/files/config_zKz1ApBZ7jZluMMX-WwnTZyMM0eVUEH6DkWwb6HxM_V0Y0izLCsKy aGVKs7EDZiAEFFWlaSJ4g/sync
C:\xampp\htdocs\D8>drush cache-clear drush 'drush' cache was cleared. [success]
C:\xampp\htdocs\D8>drush pm-update Command pm-update needs a higher bootstrap level to run - you will need to invoke drush from a more [error] functional Drupal environment to run this command. The drush command 'pm-update' could not be executed. [error] Drush was not able to start (bootstrap) the Drupal database. [error] Hint: This may occur when Drush is trying to: * bootstrap a site that has not been installed or does not have a configured database. In this case you can select another site with a working database setup by specifying the URI to use with the --uri parameter on the command line. See drush topic docs-aliases for details. * connect the database through a socket. The socket file may be wrong or the php-cli may have no access to it in a jailed shell. See http://drupal.org/node/1428638 for details.
Drush was attempting to connect to: Drupal version : 8.2.4
Site URI : http://default
Database driver : mysql
Database hostname : localhost
Database port :
Database username : root
Database name : d8
PHP configuration : C:\xampp\php\php.ini
PHP OS : WINNT
Drush script : C:/Users/samst/AppData/Roaming/Composer/vendor/drush/drush/drush.php
Drush version : 8.1.5
Drush temp directory : C:\Users\samst\AppData\Local\Temp
Drush configuration :
Drush alias files :
Drupal root : C:\xampp\htdocs\D8
Drupal Settings File : sites/default/settings.php
Site path : sites/default
Sync config path : sites/default/files/config_zKz1ApBZ7jZluMMX-WwnTZyMM0eVUEH6DkWwb6HxM_V0Y0izLCsKy aGVKs7EDZiAEFFWlaSJ4g/sync
C:\xampp\htdocs\D8>

I am running D8 with XAMPP on Windows 10. I've spent a significant amount of time searching the web for a solution. I tried changing the 'host' line in settings.php. That did not help.

  • Not sure what the solution could be to your problem, but did you already try using Acquia's Dev Desktop 2 (dev.acquia.com/downloads). It provides a "DAMP" stack, having Drush natively in it... – Watergate Dec 18 '16 at 21:55
  • I used ADD for several months until I ran into a Drush problem with it because my site is not hosted at Acquia. – Sam Stamport Dec 18 '16 at 22:34
  • I'm not using Acquia's hosting solution either, just using Dev Desktop 2 as my local development environment. – Watergate Dec 19 '16 at 9:58
  • Is Drush fully functional (all commands working) on your setup? I've not tried ADD for several months. Maybe they fixed the problem with Drush ... – Sam Stamport Dec 19 '16 at 13:01
  • 1
    Sorry, that was not the way the comment was meant. I was responding to your question whether all commands of Drush are working, if not it's not due to Acquia's Dev Desktop but to limited (development) functionality available in Windows (such as missing tools like rsync). I'm using Windows myself, so, I know from first hand how frustrating things can be and that installing these kind of applications takes a lot of effort. For me Acquia's Dev Desktop has made a lot of things (on Windows!) a lot more easier. So, I hope that this can help you too. No offence at all to Windows user, I'm one myself. – Watergate Dec 19 '16 at 23:29
0

Check if mysql binary is on your path.

Just run mysql from the same terminal window. If it works, then it will be a problem with your db config in drupal.

If it doesn't work, add the location of mysql binary C:\xampp\mysql\bin for me, to the PATH variable. It will fix it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.