0

I'm stuck on this issue, I've followed a variety of idea and tutorials trying to fix the issue, most which follow a similar path to this (http://stevenmcmurry.com/howto/2014_07/enabling-clean-urls-drupal-ubuntu-1404-lts). I'm running off of Apache2 on Ubuntu.

Currently my 000-default.conf looks like this:

<VirtualHost *:80>
        # The ServerName directive sets the request scheme, hostname and port t$
        # the server uses to identify itself. This is used when creating
        # redirection URLs. In the context of virtual hosts, the ServerName
        # specifies what hostname must appear in the request's Host: header to
        # match this virtual host. For the default virtual host (this file) this
        # value is not decisive as it is used as a last resort host regardless.
        # However, you must set it for any further virtual host explicitly.
        #ServerName www.example.com

        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html

        <Directory /var/www/html/>
    AllowOverride All
    Order Allow,Deny
    Allow from all
</Directory>
# error, crit, alert, emerg.
        # It is also possible to configure the loglevel for particular
        # modules, e.g.
        #LogLevel info ssl:warn

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined

        # For most configuration files from conf-available/, which are
        # enabled or disabled at a global level, it is possible to
        # include a line for only one particular virtual host. For example the
        # following line enables the CGI configuration for this host only
        # after it has been globally disabled with "a2disconf".
        #Include conf-available/serve-cgi-bin.conf

</VirtualHost>

But I'm still running into the issue of clean URL's not allowed to be enabled. The odd thing I'm trying to work on is at the moment, I can't see the .htaccess in the drupal site root.

Has anyone run across a situation like this?

Thanks!

4
  • Did you restart apache after making the change? sudo services apache2 restart. As the link mentions, you can download Drupal 7.53.zip and inside the zip file there should be a .htaccess fille, so upload it to your server.
    – No Sssweat
    Dec 29 '16 at 0:08
  • Does apache2ctl -M | grep rewrite return anything?
    – Clive
    Dec 29 '16 at 0:12
  • @Clive - your suggestion returned the following: AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message rewrite_module (shared)
    – Matthew
    Dec 29 '16 at 7:24
  • @NoSssweat - it appears you were right about the .htaccess file, apparently my sneaky Ubuntu decided the files with "." prefixes shouldn't be moved along with the rest of the download directory. I appreciate it!
    – Matthew
    Dec 29 '16 at 7:47
0

Mostly .htaccess is hidden While viewing cpanel click to show hidden files also, Else download .htaccess file and put it on root directory

0

It appears Ubuntu decided the files with "." prefixes shouldn't be moved along with the rest of the download directory. Redownloaded .htaccess and moved .htaccess file with sudo command from download file to drupal root folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.