3

I installed Drupal 8.2.4 and the IceMagic-8.x-1.0 theme. How do I hide the authoring information on articles?

1 Answer 1

4

Edit the node type, in the "Display settings", there is a checkbox "Display author and date information", turn that off.

6
  • In Home > Administration > Structure > Content types > Display Settings (Display author and date information), I've had already turned it off, but the author and date still show. Even after clearing the cache.
    – alex banha
    Jan 2, 2017 at 4:01
  • By the way, ther is an option to make the images responsive in Home > Administration > Appearance >Appearance settings > (Ice Magic) > Images > Responsive Images, that doesn't work either. I had to edit the styles.css and add "img { max-width: 100%; height: auto; }". Did you tried it with IceMagic?
    – alex banha
    Jan 2, 2017 at 4:06
  • No, not field display settings. Edit the node type, then in the vertical tab.
    – Berdir
    Jan 2, 2017 at 7:08
  • 1
    Yes, I think that's what I did. The URL is MY_SITE/admin/structure/types/manage/article, then in the vertical tab I chose "Display Settings" and unchecked "Display author and date information". But the author info and date still shows on articles. I am working with a multisite solution, with only one core Drupal installation. I edited sites.php, created 2 folders, etc., and disabled authoring info on both sites, but it doesn't work on either site. Can it be a bug of the IceMagic theme?
    – alex banha
    Jan 2, 2017 at 13:12
  • 1
    Could be, yes. check its node.html.twig template and compare it to the default in the classy theme.
    – Berdir
    Jan 2, 2017 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.