3

I am using a contextual filter for a view in Drupal 8. The contextual filter is a Taxonomy Term: name filter with a term relationship. It works correctly.

I'm now trying to override the title using this filter. In previous versions of Drupal, using %1 would have given me the argument. But not in Drupal 8. Is there a way to either get the argument or (even better) the term name into the title override?

3

or (even better) the term name into the title override?

1) Add Taxonomy term: Name as a field

  • Check Exclude from display
  • Uncheck Link this field to its taxonomy term page

2) Click on Title: and put {{ name }}

  • 1
    I can tell you are new here, you can accept my answer by clicking the ✅ checkmark, thx. – No Sssweat Jan 9 '17 at 0:55
  • Hi @No Sssweat, what if I'm using Teaser view mode, and not field. I already set using override title using {{ arguments.name }}, but it doesn't seem to work. – Permana Aug 1 '18 at 8:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.