7

How can I prevent the admin UI switching to a foreign language every time I translate a piece of content?

i.e. I'm editing a Menu item and I've clicked the Translate tab. I click 'Add' in the German row to add a translation.

However the link always begins /de, which means all the UI labels change as well - to get back to English I have to manually remove it from the address bar and (it seems) do so every single time.

Is there any way to turn this off?

I tried going to Detection and Selection (/admin/config/regional/language/detection) and checking 'Account Administation pages', or checking 'User' and promoting it to the top of the list, but this didn't seem to make any difference to the button URL or the form output.

6

This functionality is partially achievable since Drupal 8.6.4.

  1. Navigate to Detection and selection (admin/config/regional/language/detection)
  2. Adjust your settings accordingly. Be sure to activate "Account administration pages". Your content language detection methods are optional.

    enter image description here

  3. Edit your user profile and set your "Administration pages language" to English.

Now your Admin UI will stay in English no matter what the other language detection methods resolve to. That means while creating a translation, the interface will remain in English.

However, the unsupported part is keeping the Admin Toolbar in English when being redirected to the translated page on saving it. But when going back to the Admin UI it's in English again.

These issues are dealing with that: https://www.drupal.org/project/drupal/issues/2313309

And if you use the Admin Toolbar module: https://www.drupal.org/project/admin_toolbar/issues/3004575

  • Even though this doesn't work for me you get +1 for providing the issue links. That this problem even exists is absolutely ridiculous. – plocks Feb 12 at 15:28
4

This can be done from within the user edit page. I took the following steps from this link: https://www.drupal.org/node/2623206 [comment #8]

1- Enabled the Language module, and set-up one additional language. enter image description here

2- I configure the administration language separate to the content language by below setting:

/admin/config/regional/language/detection:
Account administration pages: enabled

enter image description here

3-Admin -> Edit Profile -> Edit(Tab) enter image description here

  • 2
    After doing this on the latest version of Drupal, I find myself unable to edit any page in a different language than the user selected one – Philippe Gilbert Oct 25 '18 at 17:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.